11-散列2 Hashing (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(k**ey)=k**ey%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

1
2
3
4 4
10 6 4 15
//结尾无空行

Sample Output:

1
2
0 1 4 -
//结尾无空行

代码

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
//hs-1-2.c
#include<stdio.h>
#include<math.h>
#include<string.h>
#define MAX 100005
int H[MAX];

int Hash(int x,int m) {
int k = 1;
int pos;
pos = x%m;
if(H[pos] == -1) {
H[pos] = 1;
return pos;
}else {
while(H[pos] != -1) {
if(H[(pos+k*k)%m] == -1) {
H[(pos+k*k)%m] = 1;
return (pos+k*k)%m;
}
k++;
if(k>=m) return -1;
}
}

}

int NextPrime(int N)
{
int i,p=(N%2)?N+2:N+1;
if (N==1) return 2;
while(p<=MAX) {
for(i=(int)sqrt(p);i>2;i--)
if(!(p%i)) break;
if(i==2) break;
else p+=2;
}
return p;
}
int main()
{
int m,n,x;
int i;
int flag = 1,t;
scanf("%d%d",&m,&n);
m = NextPrime(m);
for(i=0;i<m;i++) H[i] = -1;
for(i=0;i<n;i++) {
scanf("%d",&x);
if(flag) flag =0;
else printf(" ");
t = Hash(x,m);
if(t != -1) printf("%d",t);
else printf("-");
}
return 0;
}